ANDROID 2.3 GINGERBREAD Y HONEYCOMB 3.0

Fecha actualización el 2016-11-22. Fecha publicación el . Categoría: Android. Autor: Mapa del sitio

Android 2.3 Gingerbread y Honeycomb 3.0 pierdan los servicios de asistencia de Google Play

Google ha anunciado que abandonará el soporte para algunas de sus versiones anteriores de Android cuando se entrega la próxima actualización de sus bibliotecas Play Services.

La última versión es compatible nivel de la API de Android 9, que va todo el camino de vuelta a Android 2.3. Pero cuando la versión 10.2.0 de la Google Play bibliotecas de cliente de servicios se libera, Google aumentará el nivel mínimo soportado API a 14, por lo que Android 4.0.1 Ice Cream Sandwich la versión más antigua con el apoyo del sistema operativo. Ese cambio será inevitable ver el fin del soporte para Android 3.0 Honeycomb también.

oogle explicó: La plataforma de Gingerbread tiene casi seis años de edad. Muchos desarrolladores de Android ya han dejado de soportar Gingerbread en sus aplicaciones. Esto les ayuda a construir mejores aplicaciones que hacen uso de las nuevas capacidades de la plataforma Android. Para nosotros, la situación es la misma. Al hacer este cambio, vamos a ser capaces de proporcionar un conjunto más robusto de herramientas para desarrolladores de Android con mayor velocidad.

Los últimos datos oficiales de Google muestra que el 1,3% de los dispositivos Android están ejecutando ahora Gingerbread, mientras que menos del 0,1% están Honeycomb, y Google dice que cree "que muchos de estos viejos dispositivos no están siendo utilizados de forma activa".

Mientras que los dispositivos de Gingerbread y de Honeycomb de más edad aún tendrán acceso a los servicios de Google Play usando la versión 10.0.0 bibliotecas, las aplicaciones construidas y mantenidas con las bibliotecas más recientes 10.2.0 ya no trabajar en esas versiones anteriores del sistema operativo. Google dice que los desarrolladores "pueden crear varios archivos APK que admiten distintos niveles mínimos de API, con diferentes versiones de servicios de Google Play" - pero es poco probable que muchos desarrolladores estarán dispuestos a poner en el esfuerzo requerido para ello por una pequeña proporción de usuarios de tales .

Google recomienda que los desarrolladores se centran ahora en el nivel API 14 y Android 4.0.1 como versión mínima admitida, y que debe "interrumpir el soporte para los niveles de API que ya no van a recibir actualizaciones de servicios de Google Play".

Google todavía no ha anunciado una fecha exacta para estos cambios, pero dice que la versión 10.2.0 de las bibliotecas de cliente de servicios de Google Play se dará a conocer "a principios de 2017".


Comenta y comparte en Compartir en Google+
Android 2.3 Gingerbread