Error Samba permite el acceso a rutas prohibidas para compartir raices

linux

Durante casi un año, los actores de amenazas podrían explotar una vulnerabilidad en el software Samba que les permitía eludir los permisos para compartir archivos y escapar fuera del directorio raíz compartido.

La falla de seguridad se introdujo en Samba 4.9.0, lanzada el 13 de septiembre de 2018, y se puede aprovechar bajo ciertas condiciones.

Error de reinicio de caché

La explotación es posible en sistemas donde la opción 'enlaces anchos' en el archivo de configuración de Samba está activada. También necesitan permitir enlaces anchos inseguros (la configuración 'permitir enlaces anchos inseguros' está establecida en 'sí') o tener el parámetro 'extensión de Unix' establecido en 'no'.

El problema, que ahora se identifica como CVE-2019-10197, surge de la imposibilidad de restablecer el caché que realiza un seguimiento de los cambios exitosos en el directorio.

"Si un cliente no tiene permisos para ingresar al directorio raíz compartido, obtendrá ACCESS_DENIED en la primera solicitud", explica el aviso de seguridad .

Un cambio exitoso del directorio debería restablecer el caché registrando la solicitud denegada. Si esto no sucede, la siguiente solicitud SMB "operará en silencio en el directorio incorrecto en lugar de devolver ACCESS_DENIED".

La ubicación podría ser el directorio raíz de un recurso compartido diferente al que el cliente accedió antes o incluso el directorio raíz global del sistema.

Sin embargo, el problema no afecta las comprobaciones de permisos de Unix en el núcleo.

"El token de Unix (uid, gid, lista de grupos) siempre se suplanta correctamente antes de cada operación, por lo que el cliente todavía está restringido por los permisos de Unix impuestos por el núcleo".

El nivel de gravedad es extremadamente crítico, ya que la puntuación calculada por los mantenedores de Samba es de 8.7. Otras organizaciones calcularon un puntaje más severo , de 9.1.

Solucionando el problema

Se han lanzado parches y se recomienda a los administradores que los apliquen si ejecutan versiones de Samba inferiores a 4.9.13 y 4.10.8 , o instalan las últimas versiones estables. Samba 4.11.0 RC3 también está disponible con una solución para CVE-2019-10197.

Si no es posible aplicar la corrección, Samba proporciona las siguientes tres acciones de mitigación para elegir:

  • Use la herramienta 'sharesec' para configurar un descriptor de seguridad para el recurso compartido que sea al menos tan estricto como los permisos en el directorio raíz del recurso compartido.
  • Use la opción 'usuarios válidos' para permitir solo usuarios / grupos que puedan ingresar al directorio raíz compartido.
  • Elimine 'wide links = yes' si realmente no es necesario.
  • En algunas situaciones, podría ser una opción usar 'chmod a + x' en el directorio raíz compartido, pero debe asegurarse de que los archivos y subdirectorios estén protegidos por permisos más estrictos. También es posible que desee 'chmod aw' para evitar nuevos archivos y directorios de nivel superior, que pueden tener permisos menos restrictivos

Semrush sigue a tu competencia


Fecha actualizacion el 2019-09-05. Fecha publicacion el 2019-09-05. Categoria: linux Autor: Oscar olg Mapa del sitio Fuente: bleempingcomputer Version movil