Fallo de Systemd provoca el secuestro de maquinas Linux vulnerables

Systemd se ve afectado por una vulnerabilidad de seguridad que puede explotarse para bloquear una máquina Linux vulnerable y, en el peor de los casos, ejecutar código malicioso.

Un atacante puede desencadenar la vulnerabilidad utilizando paquetes DHCPv6 creados con fines malintencionados y modificando partes de la memoria de los sistemas vulnerables, lo que podría provocar la ejecución remota de código.

La falla, rastreada como CVE-2018-15688 , fue informada por Felix Wilhelm, del equipo de seguridad de Google. Wilhelm explicó que un atacante puede desencadenar el desbordamiento de manera sencilla al anunciar un servidor DHCPv6 con un id de servidor> = 493 caracteres de largo.

"La función dhcp6_option_append_ia se usa para codificar Asociaciones de Identidad recibidas por el servidor en el búfer de opciones de un paquete DHCPv6 saliente ", escribió Wilhelm.

“La función recibe un puntero a la opción buf Buff, el tamaño restante es buflen y el IA se agrega al búfer. Mientras que la comprobación en (A) intenta asegurarse de que el búfer tenga suficiente espacio para almacenar la opción IA, no toma en cuenta los 4 bytes adicionales del encabezado DHCP6Option (B). Debido a esto, el memcpy en (C) puede salirse de límite y * buflen puede desbordarse en (D), lo que le da a un atacante una escritura de pila OOB muy potente y ampliamente controlada que comienza en (E). El desbordamiento se puede desencadenar con relativa facilidad anunciando un servidor DHCPv6 con una ID de servidor> = 493 caracteres de largo ".

La falla reside en el cliente DHCPv6 de la suite de administración de código abierto Systemd que se implementa en varias distribuciones de Linux (Ubuntu, Red Hat, Debian, Fedora, CoreOS, Mint y SUSE Linux Enterprise Server).

Si la compatibilidad con IPv6 está habilitada, el cliente DHCPv6 de la suite de administración Systemd de código abierto se activa automáticamente para procesar los empacadores que llegan.

Los expertos señalaron que los clientes DHCPv6 podrían ser despertados por mensajes de anuncio de enrutador especialmente diseñados enviados por un servidor DHCPv6 fraudulento en una red o en un ISP. En ambos escenarios, los atacantes pueden habilitar a los clientes DHCPv6 y desencadenar la vulnerabilidad para bloquear o secuestrar las máquinas Linux que funcionan con Systemd.

Tanto Ubuntu como Red Hat Linux publicaron un aviso de seguridad sobre el tema. resumen:

“Systemd - networkd es vulnerable a un montón de escritura fuera de los límites en el cliente DHCPv6 al manejar opciones enviadas por los servidores DHCP de red adyacentes. Un atacante podría explotar esto a través del servidor DHCP malicioso para corromper la memoria del montón en las máquinas cliente, dando como resultado una denegación de servicio o una posible ejecución de código ", lee el aviso publicado por Red Hat.

"Felix Wilhelm descubrió que el cliente dhcp6 de systemd-networkd podía escribir más allá de los límites (desbordamiento de búfer) de un búfer asignado al responder a un servidor dhcp6 con un parámetro de identificación de servidor demasiado largo", lee el aviso publicado por Ubuntu.

Semrush sigue a tu competencia


Fecha actualización el 2018-10-30. Fecha publicación el 2018-10-30. Categoria: linux Autor: Oscar olg Mapa del sitio Fuente: securityaffairs
linux