Nueva revision del kernel de Linux para todas las versiones de Ubuntu

Canonical lanza una nueva actualización importante de seguridad del kernel de Linux para todos los lanzamientos compatibles de Ubuntu para corregir varias vulnerabilidades descubiertas recientemente por investigadores de seguridad.

Disponible ahora para los sistemas Ubuntu 18.04 LTS (Bionic Beaver), Ubuntu 16.04 LTS (Xenial Xerus) y Ubuntu 14.04 LTS (Trusty Tahr), los nuevos parches de seguridad del kernel de Linux abordan un total de once vulnerabilidades que afectan a Linux 4.15, 4.4 y 3.13 núcleos de los lanzamientos de Ubuntu antes mencionados y sus derivados.

Entre las correcciones, podemos observar una vulnerabilidad de uso después de la liberación ( CVE-2018-17182 ) descubierta por Jann Horn en el subsistema vmacache del kernel de Linux, que podría permitir que un atacante local bloquee el sistema, así como un desbordamiento de búfer basado en la pila ( CVE-2018-14633 ) en la implementación del objetivo iSCSI, que permite que un atacante remoto bloquee el sistema.

El parche de seguridad también aborda un error ( CVE-2018-15594 ) en la implementación de paravirtualización del kernel de Linux que puede reducir la efectividad de las mitigaciones de Specter v2 para invitados paravirtuales, así como la vulnerabilidad spectre_v2_select_mitigation ( CVE-2018-15572 ) que podría permitir a los atacantes exponer información sensible.

Otras correcciones incluyen una vulnerabilidad ( CVE-2018-10853 ) en la implementación de KVM del kernel de Linux que permite a los usuarios sin privilegios en una VM invitada escalar sus privilegios dentro del invitado, así como una pérdida de memoria ( CVE-2018-6554 ) y un uso vulnerabilidad posterior a la liberación ( CVE-2018-6555 ) en el subsistema IRDA del kernel de Linux.

Específico solo para los sistemas Ubuntu 16.04 LTS (Xenial Xerus), el parche de seguridad corrige una referencia de puntero NULL ( CVE-2017-18216 ) en la implementación del sistema de archivos OCFS2 del kernel de Linux, una condición de carrera ( CVE-2018-10902 ) en el controlador MIDI sin procesar y una vulnerabilidad ( CVE-2018-16276 ) en el controlador de dispositivo USB de YUREX.

Específico solo para los sistemas Ubuntu 1404 LTS (Trusty Tahr), el parche de seguridad corrige una vulnerabilidad de desbordamiento de enteros ( CVE-2018-14634 ) descubierta en el kernel de Linux al cargar un ejecutable para ejecutar, lo que podría permitir a un atacante local obtener privilegios administrativos.

Canonical insta a todos los usuarios de Ubuntu a actualizar sus instalaciones de inmediato a las nuevas versiones del kernel, que son linux-image 4.15.0-36.39 para Ubuntu 18.04 LTS, linux-image 4.4.0-137.163 para Ubuntu 16.04 LTS, linux-image 3.13.0 -160.210 para Ubuntu 14.04 LTS, linux-image 4.15.0-36.39 ~ 16.04.1 para Ubuntu 16.04.5 HWE, y linux-image 4.4.0-137.163 ~ 14.04.1 para Ubuntu 14.04.5 HWE.

Los usuarios de Ubuntu 12.04 ESM también deberían actualizar su sistema al linux-image 3.13.0-160.210 ~ precise1 HWE kernel de Ubuntu 14.04 LTS. Los kernels de Linux actualizados también están disponibles para Raspberry Pi 2, sistemas AWS, sistemas GCP, entornos de nube, procesadores Snapdragon y procesadores OEM en Ubuntu 18.04 LTS y Ubuntu 16.04 LTS. ¡Actualice sus instalaciones lo antes posible!

Semrush sigue a tu competencia


Fecha actualización el 2018-10-03. Fecha publicación el 2018-10-03. Categoria: linux Autor: Oscar olg Mapa del sitio Fuente: softpedia
linux